How to use this box with Vagrant:

Vagrant.configure("2") do |config|
  config.vm.box = "envimation/ubuntu-xenial-docker"
  config.vm.box_version = "1.0.0-1515550301"
end
vagrant init envimation/ubuntu-xenial-docker \
  --box-version 1.0.0-1515550301
vagrant up

This version was created almost 2 years ago.

Ubuntu Xenial Docker

Reliable, high quality, up-to-date(daily built) image of Ubuntu Xenial 64bit with docker and docker compose.

Test Results

Test Results vmware


Test Results virtualbox

  System Package
     ✔  docker-ce should be installed
  Service docker
     ✔  should be enabled
     ✔  should be running
  #<Hashie::Mash Client=#<Hashie::Mash
     ✔  ApiVersion="1.35" Arch="amd64" BuildTime="Wed Dec 27 20:11:19 2017" DefaultAPIVersion="1.35" GitCommit="c97c6d6" GoVersion="go1.9.2" Os="linux" Platform=#<Hashie::Mash Name=""> Version="17.12.0-ce"> Server=#<Hashie::Mash ApiVersion="1.35" Arch="amd64" BuildTime="2017-12-27T20:09:53.000000000 00:00" Components=#<Hashie::Array [#<Hashie::Mash Details=#<Hashie::Mash ApiVersion="1.35" Arch="amd64" BuildTime="Wed Dec 27 20:09:53 2017" Experimental="false" GitCommit="c97c6d6" GoVersion="go1.9.2" KernelVersion="4.4.0-108-generic" MinAPIVersion="1.12" Os="linux"> Name="Engine" Version="17.12.0-ce">]> GitCommit="c97c6d6" GoVersion="go1.9.2" KernelVersion="4.4.0-108-generic" MinAPIVersion="1.12" Os="linux" Platform=#<Hashie::Mash Name=""> Version="17.12.0-ce">> Server.Version should cmp >= "1.17"
     ✔  ApiVersion="1.35" Arch="amd64" BuildTime="Wed Dec 27 20:11:19 2017" DefaultAPIVersion="1.35" GitCommit="c97c6d6" GoVersion="go1.9.2" Os="linux" Platform=#<Hashie::Mash Name=""> Version="17.12.0-ce"> Server=#<Hashie::Mash ApiVersion="1.35" Arch="amd64" BuildTime="2017-12-27T20:09:53.000000000 00:00" Components=#<Hashie::Array [#<Hashie::Mash Details=#<Hashie::Mash ApiVersion="1.35" Arch="amd64" BuildTime="Wed Dec 27 20:09:53 2017" Experimental="false" GitCommit="c97c6d6" GoVersion="go1.9.2" KernelVersion="4.4.0-108-generic" MinAPIVersion="1.12" Os="linux"> Name="Engine" Version="17.12.0-ce">]> GitCommit="c97c6d6" GoVersion="go1.9.2" KernelVersion="4.4.0-108-generic" MinAPIVersion="1.12" Os="linux" Platform=#<Hashie::Mash Name=""> Version="17.12.0-ce">> Client.Version should cmp >= "1.17"
  File /usr/local/bin/docker-compose
     ✔  should be executable by user vagrant
  Command docker-compose
     ✔  --version stdout should cmp == /docker-compose version 1\.*.*/i
  Command docker
     ✔  run busybox echo "hello world" stdout should cmp == /hello world/i
  Command apt-get
     ✔  update stderr should eq ""
     ✔  update exit_status should eq 0
  Command DEBIAN_FRONTEND="noninteractive"
     ✔  apt-get install --no-install-recommends --assume-yes sshpass exit_status should eq 0
  Command sshpass
     ✔  -p "vagrant" ssh -o StrictHostKeyChecking=no vagrant@localhost exit exit_status should eq 0
Test Summary: 12 successful, 0 failures, 0 skipped
1 provider for this version.
  • virtualbox Hosted by Vagrant Cloud (257 MB)