How to use this box with Vagrant:

Vagrant.configure("2") do |config|
  config.vm.box = "cybersecurity/metasploitable2"
  config.vm.box_version = "0.0.1"
end
vagrant init cybersecurity/metasploitable2 \
  --box-version 0.0.1
vagrant up

This version was created about 1 month ago.

Hyper-V provider for Rapid 7's Metasploitable 2.

This version does not contain conventional conveniences, such as a vagrant user, etc. This only provides a base Metasploitable 2 instance that can be launched on Hyper-V.

1 provider for this version.
  • hyperv Hosted by Vagrant Cloud (935 MB)